Use the mount command in the container instead of adding the --devcide parameter to docker run

I use the Insmod command to load the module on the host, and then
start the container with the following command
docker run it --device /dev/aaa
and the binary file can be successfully run in the container.

But if start the container with the following parameters
dockr run -it -v /dev:/xxx/dev --cap-add=ALL
and execute the command
mount /xxx/dev /dev
in the container, “driver not loaded” error is reported when running the program. I don’t know much about the operating system. Why can’t I replace the --device parameter with the mount command in the container by myself?